Powerup and initialization

From BEASTX Wiki
Jump to: navigation, search
This page is a translated version of the page Help:FAQ:Powerup and the translation is 100% complete.


MICROBEAST does not finish initialization. What can I do?

Watch the running LED lights during the init phase: If the lights A - G light up the sensor's rest positions are being calibrated, H - N show determining the RC channels and their center positions. MICROBEAST/AR7x00BX: Initially the chase is from A - N. If one step is done the indication light for this step will quit running. MICROBEAST PLUS: Initially the chase is from H - N (Stick calibration). Only if this step is finished the chase from A - G (Sensor calibration) will start.

When LEDs A - G do not quit running

  • The sensors register movement and calibration of rest position can not be finished. Make sure the unit/the helicopter does not get moved e.g. by wind gusts or people leaning on your work bench where the heli is standing on.
  • Sensors damaged. Return the device for repair.
  • Power supply voltage is dropping due to weak power supply or damaged servos.


When LEDs H - N do not quit running

  • Check whether the receiver sends out control signals and that all cables are properly connected to the MICROBEAST/MICROBEAST PLUS. In particular make sure the plugs are inserted with correct polarity and not offset to the pin connectors of the MICROBEAST.
  • Is the correct type of receiver selected in the receiver setup menu? Particularly when using a SPEKTRUM radio system note that receivers like SPEKTRUM AR6100, 7000, 9000 etc. are "Standard" receivers! The selection of "SPEKTRUM" in the receiver setup menu only applies for direct connection of one single SPEKTRUM satellite with the optional available adapter. In general when using a serial-wire receiver check if the Status-LED lights up in "blue" color at Receiver setup menu point B indicating there is a valid signal coming from the receiver.
  • When using a Standard receiver check the wiring. Mainly check receiver wires for polarity on both sides and correct plugging (no vertical offset by one pin).
  • MICROBEAST/MICROBEAST PLUS: Check binding between transmitter and receiver.
  • AR7200BX/AR7300BX: Check binding between transmitter and receiver.


The brand new MICROBEAST only shows a red flashing LED, random LED sequence or even nothing. What's wrong?

Check very carefully that all cables are plugged in correctly and all the plugs are connected properly at the correct position on both MICROBEAST and receiver side. Especially in the vertical direction make sure not just 2 pins sit on the header. Also make sure that the polarity is correct on all connections. Make sure your power supply (BEC or receiver battery) is capable to power all connected devices (servos, receiver, flybarless). When the power drain is too high this can cause a short drop in voltage making the system resart over and over again.